6
$\begingroup$

How can I adjust the axis labels in ds9?

I'd like to have something like: enter image description here

So far I only managed to get floating points (tl h%f3):
enter image description here

or the leading hours are missing (tl h%f1 m):

enter image description here


Edit:

I tried "tlhm.1" as kindly suggested by Jeremy, but unfortunatly it still does not work:

enter image description here

$\endgroup$
3
  • $\begingroup$ Ask Chief O'Brien to recalibrate the sensors? $\endgroup$
    – user21
    Commented Feb 10, 2014 at 23:09
  • 1
    $\begingroup$ Good suggestion, but I am afraid this will not help, because the measurement is perfectly fine - it is just a matter of visualization $\endgroup$ Commented Feb 11, 2014 at 9:42
  • $\begingroup$ I've added your ds9 and plotting tags, so you can edit that comment out of your question (or I can do it for you) $\endgroup$
    – Jeremy
    Commented Apr 4, 2014 at 10:53

2 Answers 2

2
$\begingroup$

The DS9 Reference Manual, p42, 'Numeric Formats'. http://ds9.si.edu/doc/ref/ref.pdf#page48 has a bunch of information.

Based on that, I expected that "tlhm.1" would achieve what you proposed.

However, it seems that SAOImage DS9 is very keen on dropping leading hours it sees as unnecessary, even if you have specified them in a format specifier.

I haven't been able to figure out a format specifier combination that retains the hours for every gridline while also showing the minutes or seconds.

I have searched elsewhere for advice on this and haven't found it either. In fact, I haven't been able to find any comment on the hours being suppressed, nothing that explains why it does this, nor even anyone else remarking or complaining about it.

I suggest sending an email to the DS9 Help Desk address found in the menu under Help > Help Desk.

$\endgroup$
4
  • $\begingroup$ Thanks for posting an answer. I already tested various options from the reference manual and also combinations thereof, but how can I manage to not discharge leading hours? $\endgroup$ Commented Mar 13, 2014 at 11:15
  • $\begingroup$ thanks for your suggestion, unfortunately it did not work $\endgroup$ Commented Apr 2, 2014 at 15:59
  • $\begingroup$ @samcarter ok, that's flaming frustrating isn't it. I've spend an hour fiddling with formatting options and it just seems to suppress the leading hours on most of the grid lines, pretty much ignoring the format specifiers that detail how you want it! $\endgroup$
    – Jeremy
    Commented Apr 4, 2014 at 10:41
  • $\begingroup$ Thanks a lot for all your effort! Hard luck your solution did nor work :( $\endgroup$ Commented Apr 4, 2014 at 15:41
0
$\begingroup$

If there is anybody out there how is able to answer this question, please feel free to do so ... in the meanwhile I do not what to post an answer but an (annoyingly timeconsuming and unautomated) workaround:

Workaround

  • Print your ds9 plot to a .ps file

enter image description here

  • convert this .ps file to .pdf
  • adjust the axis labels with some vector graphic editing tool like Inkscape enter image description here
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .