I downloaded fits file using wget script from https://exoplanetarchive.ipac.caltech.edu/docs/datasethelp/ETSS_CoRoT.html I am not able to view the file. I tried atsromagic and DS9 . After File->Open I get an error message "..error while reading.." .It happens with both softwares. Is anyone able to view these files? If yes, which software did you use? Another possibility is that using using wget script on windows it got corrupted. Is there a command line tool to check integrity/validity of fits file?


1 Answer 1


These are FITS binary tables not FITS images so the normal FITS image tools very likely won't read them. You have a couple of options to examine and manipulate them:

  • Use the 'fv' tool which works on FITS images or tables (and integrates with ds9)
  • Use TOPCAT, a very powerful tool for examining, plotting and many other operations on all formats of tables (not just FITS ones)
  • Use Python and AstroPy Tables e.g.
from astropy.table import Table

table = Table.read('EN2_STAR_CHR_0102990364_20070206T133547_20070401T235934.fits') 
<Table length=71042>
          DATE                DATEJD            DATEHEL       STATUS ...     BG    CORREC_RED CORREC_GREEN CORREC_BLUE
  yyyy-mm-jjThh:mi:ss    COROT JULIAN DAY   COROT JULIAN DAY         ... ELECTRONS ELECTRONS                          
        bytes23              float64            float64       int32  ...  float32   float32     float32      float32  
----------------------- ------------------ ------------------ ------ ... --------- ---------- ------------ -----------
2007-02-06T13:35:47.000   2593.06626508258 2593.0705519515977     16 ... 373.35654        0.0          0.0         0.0
2007-02-06T13:44:19.000  2593.072191038021 2593.0764776164892      0 ... 378.81073        0.0          0.0         0.0
  • $\begingroup$ 'fv' worked for me. $\endgroup$
    – qqqqq
    Commented Oct 25, 2019 at 21:52
  • $\begingroup$ Mentioning so that it saves other people time. I attempted to install TOPCAT. It needed JRE. But the download site of JRE seems to require an ORACLE id. I gave up at that point. $\endgroup$
    – qqqqq
    Commented Oct 28, 2019 at 23:00
  • $\begingroup$ Hmm, this seems to be something Oracle have changed recently. The Open JDK should work just as well (and doesn't require signing up) $\endgroup$ Commented Oct 29, 2019 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .